401レス(7/9)
300:
名無しさん2021/11/20(土) 20:49:54 A1rCPamo
2つ以上のアドレスにhotentryをメールで送りたいのですが、mailコマンドで最新のhotentryファイルを指定する方法はありますか?
今のところnarou setting hotentry.auto-mail=trueとしてひとつのアドレスにだけは送信できています。
301:
名無しさん[sage] 2021/11/20(土) 23:27:56
すみませんhelp見落としてました。自己解決です
302(1):
名無しさん[sage] 2021/11/25(木) 08:19:18
Narou.rbはKindle Paperwhiteの第11世代(2021)でも問題なく使えるでしょうか?
303(1):
名無しさん2021/11/26(金) 03:48:44 TfV2igVk
>>302
日本で発売しているモデルなら初代でも最新でも使えますよ
304:
名無しさん[sage] 2021/11/26(金) 07:11:44
>>303
了解です!
305(1):
ぽん2021/11/26(金) 10:35:30 7/zFEDeg(1/2)
いつも愛用させていただいてます
narou webの方からmail送信のチェックをつけてKindleへ送っているのですが、
本日小説をダウンロードしたところダウンロードは正常に行われるのですが、Kindleへのメール送信のところで以下のエラーが出てしまいました。

[ERROR]535-5.7.8 Username and Password not accepted. Learn more at

パスワードとユーザーネーム(アドレス?)を再登録する必要があるようなことが書いてあるのはわかるのですが、cmd入力については初心者で、具体的にどこにどんな文字を入れて手直ししたら良いのかわかりません。
お手数かけてすみませんが教えていただけたら助かります。

Narou.rbは3.8.0が入っています
Windows10です
よろしくお願いします
307:
ぽん2021/11/26(金) 11:22:30 7/zFEDeg(2/2)
無事解決しました
ありがとうございました
308(2):
名無しさん[sage] 2021/11/28(日) 07:24:08
Paperwhite(2021)を購入したのでnarou.rbからいくつか小説を入れてみたのですが、文章が少し右側に寄って表示されてしまいます。
左端に一行空きがある感じです。Paperwhite(2018)では右側に寄る様子はなかったのですが・・・
何か設定の変更が必要でしょうか?
309(1):
名無しさん2021/11/28(日) 17:20:34 xFDayrpg
>>308
Kindle Previewerを更新して、kindlegenを入れ替えたら。
310(1):
名無しさん2021/11/29(月) 06:08:50 tqu2.K/g
>>308
AozoraEpub3の行の高さや、KindlePWの行間設定を見直すといいと思います
具体的にどんな値がよいのかはわかりませんが、1.6になっているなら1.5にするとか
311(1):
名無しさん[sage] 2021/12/04(土) 14:19:01
>>309
>>310
すみません、レス遅くなりました。
kindlegenの更新は効果がなく、narou initから行間を1.8→1.75に変更すると、左右の不均衡が多少軽減されました。
これで使ってみます。
312(1):
名無しさん2021/12/05(日) 02:02:42 L2AQFG5g
>>311
古い AozoraEpub3 では、Kindle本体で行える行間設定が正常に動作しなかった記憶があります

もし、古い AozoraEpuba3 を使っているのであれば、
改造版AozoraEpub3 を narou init を使わずに手動で設定したうえで、
AozoraEpub3 の設定で行間設定をする方がよいかと

手動設定の方法は過去レスのどこかにあります
313:
名無しさん[sage] 2021/12/05(日) 14:37:22
>>312
narou initを使わずにAozoraEpub3の場所を指定する方法がよくわからなかったのですが、

改造版AozoraEpub3-1.1.1b10Qを適当な場所に解凍・kindlegen.exeを入れる
→narou initで改造版のフォルダを指定、行間を適当に入力(vertical_font.cssが見つからずエラーが出る)
→古いAozoraEpub3のフォルダから/template/OPS/css_custom/vertical_font.cssをコピーし、改造版の/template/item/css_custom/に入れる

としたところ、左右の間隔が均等になりました。ありがとうございました。
314:
名無しさん2021/12/06(月) 18:03:27 Km7f4L3c
新しいキンドル端末では改造版AozoraEpub3でないと表示がうまく行かないということ?
315:
名無しさん2021/12/11(土) 16:07:24 G.ZYmmGk
AozoraEpub3にLog4jが入っているみたいだけど影響あるかな。
Log4jは任意のコードが実行可能な脆弱性が発見された。
316:
名無しさん2021/12/20(月) 01:16:53 YWmZ7pbs
narou listの仕様でよくわからないのですが、
narou list -t HOGEHOGE | narou list -l
と、これを逆にした
narou list -l | narou list -t HOGEHOGE
とで実行結果が異なるようです。守らなくてはいけない順序がありますか?
317:
316[sage] 2021/12/21(火) 00:15:44
意味わかりました。
これは独立したコマンドを2回使ってるだけでパイプの意味ないですね。
フィルタとして機能するように誤解してました。
318:
名無しさん[sage] 2021/12/25(土) 14:17:48
手元の環境でなろう小説で取得できてる前書き後書きがハーメルンでは取得できなくなってるんですが(以前は出力されていた)
個別のサイトごとに設定があるんでしょうか
319:
名無しさん[sage] 2021/12/25(土) 21:32:05
全てのサイトで同じ小説フォーマットが使われているわけではないので各サイトごとに個別対応する仕組みになっています
そのため各サイトの小説フォーマットが変更された場合に本文や前書き後書き等が取得できなくなることがあります

例えばハーメルンの前書き後書きのフォーマットが変更された場合ハーメルンの前書き後書きが取得できなくなります
未確認ですが今回はそれかもしれません
320:
名無しさん[sage] 2021/12/25(土) 22:50:42
結局確認してしまったので補足をしておきます
「webnovel」フォルダ内の「syosetu.org.yaml」がハーメルン用のフォーマット定義ファイルです

その「syosetu.org.yaml」の33~35行目を正しく書き換えると前書き後書きが取得できるようになりました
321:
318[sage] 2021/12/26(日) 12:38:51
自己修正は無理でしたが現状は把握できました
ありがとうございます
322(1):
名無しさん2022/01/04(火) 03:51:35 1nRKumPM
mail_setting.yamlで:authentication : :plainとあり、パスワードが平文で送られる意味と思いますが
パスワードを変更せずに日常的にnarou mailを使っても問題ないですか?
323(1):
名無しさん[sage] 2022/01/05(水) 02:27:35
>>322
もしGmailで二段階認証を使っていない場合は、Googleアカウント設定からセキュリティレベルを下げる必要があったと思います
二段階認証を使っている場合は、アプリパスワードを発行して本来のパスワードとは違うパスワードを入力します(私はこれ)
リスクを考えて自分で判断してください
324:
名無しさん[sage] 2022/01/21(金) 11:07:57
>>323
ありがとうございます。
Gmailでは二段階認証ですがアプリパスワードもフルアクセス可能とのことなので別アカウントを作ることも検討してみます。
325:
名無しさん[sage] 2022/01/21(金) 13:48:24
専用アカウント作るのが安全
ヤフーメールとかでも良い
326(1):
名無しさん2022/02/02(水) 20:29:17 ud379.RQ
初めまして。
現在自分の使っているNarou.rbのバージョンが3.7.0なので、更新しようとしたのですが、更新できませんでした。
解決策などありましたら教えていただきたいです。

macbook pro 2018
ruby 3.0.0p0
java 1.8.0_271
327:
名無しさん2022/02/08(火) 22:31:56 W5H22oKk
>>326
質問した本人です。
なんとか解決できました。
お目汚し失礼しました。
328:
名無しさん2022/02/20(日) 10:38:38 VYWc8f3M
hotentryを早く作るために

hotentry=true
convert.no-epub=true
convert.no-mobi=true
narou update --gl
narou csv | grep "modified" | rs -T | narou update -a;

としたあとで改めてnarou convertで新着のあった作品だけepub/mobiを作りたいのですが、
新着のあった作品を判断する方法はありますか?
update --glのmodifiedタグは修正のみの作品にも付いてしまうので都合が悪いです。
329(1):
名無しさん2022/02/21(月) 23:05:17 BP4sV.cw
初めまして。
書き込むのは初めてなので失礼があれば申し訳ございません。
質問なのですが、最近narou.rbで小説をkindleに送ると
【フォルダーがほぼ一杯です ドキュメントフォルダー内のサブフォルダーの
 1つに2000個以上のドキュメントがあります。デバイスにさらにドキュメント
 を追加するには、「ダウンロード」フォルダー内に新しいサブフォルダーを
 作成することをおすすめします。】
というような表示が出ます。正直すすめられてもよくわからず、この場を借り
まして質問させていただきます。
初歩的な質問だったら申し訳ないのですが、こういったときどうすればいいのでしょうか?
Kindleに入れた小説を消す以外の選択肢はあるのでしょうか?
330(1):
だんり[sp110011@gmail.com] 2022/02/22(火) 00:25:30
win10 21h2
narou.rb 3.8.1
ruby 3.1.1
目次データが取得出来ませんでした
何らかの理由により目次が取得できませんでした
331:
名無しさん2022/02/22(火) 15:57:16 OeX1D1uI
>>329
動作が重くなることがあるかもしれないけど、使えるならそのままでもよいと思う
なんとかしたいなら、kindle.rbを編集すればよいと思うが、よくわからないならいじらないほうがいい

>>330
スレ違い
それは投稿サイト側がメンテとかでアクセスできないときなんかに出ると思う
332(1):
W2022/02/23(水) 13:01:08 owsw.E3U(1/3)
gem install narouを管理者プロンプトでしたあと、フォルダを移動してnarou initをうちましたが、以下の文が出ました。
D:\[サブフォルダ\SS\MyNovel>narou init
'narou' は、内部コマンドまたは外部コマンド、
操作可能なプログラムまたはバッチ ファイルとして認識されていません。

どうしたらよいでしょうか。
333(1):
名無しさん[sage] 2022/02/23(水) 13:41:11
>>332
Rubyをインストールする時に環境変数を設定してないんじゃない?
https://github.com/whiteleaf7/narou/wiki#%E3%82%A4%E3%83%B3%E3%82%B9%E3%83%88%E3%83%BC%E3%83%AB
>途中で「Rubyの実行ファイルへ環境変数PATHを設定する」というチェックボックスが出てくるのでチェックして下さい。

手動でも追加できるけど、Rubyのインストーラを再実行して(↑をチェックして)追加するのが簡単じゃないかな?
もし手動で追加したいなら、「windows 環境変数 path」とかで検索するとやり方説明してるページが見つかるよ
https://anykey.bz/program/win10-path/
自分がRubyをインストールしたディレクトリのbinフォルダを追加してあげれば良いよ
(バージョンによって違うけど、「C:\Ruby26-x64\bin」みたいなやつ)
334(1):
W2022/02/23(水) 16:09:57 owsw.E3U(2/3)
>>333
rubyをインストールするときに全てチェックのところは記載された通りにしました。
ただそもそもgem install narouがerrorが出ていました。
C:\Users\kkk_e>gem install narou
Temporarily enhancing PATH for MSYS/MINGW...
Building native extensions. This could take a while...
ERROR: Error installing narou:
ERROR: Failed to build gem native extension.

current directory: C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/psych-4.0.3/ext/psych
C:/Ruby27-x64/bin/ruby.exe -I C:/Ruby27-x64/lib/ruby/2.7.0 -r ./siteconf20220223-10488-u9htw5.rb extconf.rb
checking for yaml.h... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers. Check the mkmf.log file for more details. You may
need configuration options.

Provided configuration options:
--with-opt-dir
--without-opt-dir
--with-opt-include続き40行
335:
<削除>[<削除>]
<削除>
336:
<削除>[<削除>]
<削除>
337:
<削除>[<削除>]
<削除>
338:
<削除>[<削除>]
<削除>
339:
<削除>[<削除>]
<削除>
340:
<削除>[<削除>]
<削除>
341:
<削除>[<削除>]
<削除>
342:
<削除>[<削除>]
<削除>
343:
名無しさん[sage] 2022/02/23(水) 19:12:56
>>334
Rubyのインストーラで「without Devkit」の方を選んじゃったんじゃない?

>Download → RubyInstallers の欄にある Ruby+Devkit 3.X.X-X (x64) をダウンロードし、インストールします。
って書いてある通り、「with Devkit」の方から選ばないとダメよ
344:
<削除>[<削除>]
<削除>
345:
W2022/02/23(水) 19:40:51 owsw.E3U(3/3)
できました。
読んだつもりだったのですが、きちんと説明書は読み込むべきですね。
ありがとうございました。
346:
<削除>[<削除>]
<削除>
347:
<削除>[<削除>]
<削除>
348:
<削除>[<削除>]
<削除>
349:
<削除>[<削除>]
<削除>
続き
 元スレ:https://jbbs.shitaraba.net/bbs/read.cgi/computer/44668/1511247073/